 JMPtm runs under the current versions of the Windows, MAC and LINIX operating systems.

JMP and SAS are registered trademarks of the SAS Institute both in the US and in other countries.

Introduction

First and foremost, JMP has numerous and powerful interactive statistical features that can be used in most data analytic environments.

JMP was designed to place special emphasis on graphical displays.  Almost all JMP analyses are accompanied by graphical reports that help to illuminate the results, both for the data analyst and for the people with whom the data analyst needs to communicate.

Introduction

Like SAStm, JMP may be used to read data stored in text files, ODBC compliant databases, EXCEL or in SAS data sets.  See the JMP User’s Guide (page 22) for a full list of the file formats you can import into JMP.  See chapter 2 of the JMP User’s Guide for information about accessing data from the Internet or from FTP sites.

You can use SQL to control what you import from a database.

Introduction

JMP may be used to export data to EXCEL, text or as SAS transport data sets.  Under WINDOWS, JMP can save data sets in a format recognized by SAS.

JMP may also be used to “export” results.

You can cut & paste results into word processing programs

You can save “journals” that may then be opened in word processing (defined broadly) programs.

You can save text files that contain the textual results but not the graphics.

You can save HTML files that do include all the graphical displays.

You can save RTF files that also include all the graphical displays.

Introduction

JMP analyses platforms operate on JMP data tables that are thus analogous to SAS data sets in the SAS programming environment.

JMP data tables “look like” spreadsheets, which is to say, rows and columns of information, both numeric and character.

JMP data tables permit many operations commonly associated with spreadsheets such as computing a column from the values in one or more other columns.  In that sense, they permit the sort of programming operations many of you associate with the SAS data step.

JMP also makes available a scripting language, JSL, that provides a programming environment which greatly extends JMP capabilities since it provides access to all the standard programming operations.

Reading data

In order to illustrate some of the ideas already discussed we will open a data set that contains some information from a large Diabetes trial.

Treatment
 ID
base
Cramps
GAD
IA2
HBA
STANDARD
33
1

1
0.01
0
10.26 

STANDARD
35
1

0
0.02
0
10.91 

EXPER
37
1

1
0.54
0.57
9.34 

EXPER
42
1

1
0.18
0
10.41 

EXPER
72
2

0
0.09
0.67
7.21 

STANDARD
73
2

0
0.84
0.32
8.88 

STANDARD
79
1

1
0.94
0.61
9.3 

EXPER
94
1

0
0.37
0.05
8.6 

STANDARD
98
1

0
0.61
0
10.23 

EXPER
103
1

0
0.77
0.63
10.22 

EXPER
129
1

1
0.07
0
8.32 

EXPER
132
1

0
0.3
0.01
9.29 

EXPER
141
1

1
0.95
0.01
8.03 

STANDARD
151
1

0
0.65
0
9.66 

EXPER
177
1

0
0.05
0
10.02 

EXPER
186
1

1
0.76
0.55
10.7 

STANDARD
192
1

1
0.3
0
11.38 

EXPER
218
1

1
0.89
0
9.69 

STANDARD
227
1

1
0.07
0
12.03 

EXPER
248
1

0
0.35
0
9 

EXPER
277
1

1
0.01
0
11.5 

STANDARD
283
2

0
0.31
0
8.05 

EXPER
290
1

1
0.25
0.19
10.48 

EXPER
301
1

1
0.7
0
8 

STANDARD
307
1

0
0.92
0.01
6.42 

STANDARD
312
2

0
0.14
0.22
6.77 

STANDARD
314
1

1
0.08
0.25
8.14 

STANDARD
317
1

0
0.13
0.73
8.1 

STANDARD
330
2

0
0.17
0
7.36 

EXPER
347
1

1
0.12
0.59
8.59 

The above is a JMP data table.  It could have been directly imported from EXCEL or a SAS data set through the series of  commands:

Reading data
File > Open > path to data set

For a text file, after File > Open, you are presented with a choice.  You can often use “Data(Best Guess)” to open the file as a JMP data table directly.  Alternatively, you can use “Data(Using Preview)” or “Data(Using Preferences)” to open files which contain unusual formatting.  The dialog box below illustrates some of the options under Using Preview.

[image: image1.wmf]
To export a JMP data table to a format other than JMP use File > Export.  That results in a dialog box wherein you can choose text, EXCEL or SAS Transport formats.  Following that you simply specify a filename for the exported data set.  For text files additional formatting may be specified.

The JMP data table – Irvinex.jmp
[image: image2.wmf]
On the left hand side of the screen there is information about the data in an area called the data table panels.  To the right of that is the data grid.  There are 3 data table panels.  There is one part each for row & column information and one part for the data table itself.

There is no limit to the size of a JMP data table save for those imposed by your computer’s memory.  The interactive nature of JMP means all the data must be stored in RAM.

Metadata

The table area of the data table panel contains information about the JMP data table.  Among the things that may be stored there are: notes that document the nature and source of the information in the table, scripts that contain “programs” that both document and allow replication of completed analyses and, the ability to lock a table to access.

The columns panel lists the columns (variables) in the table along with information about each column.  That information includes such things as modeling type and other column properties.

· Modeling type refers to whether the variable is continuous, nominal or ordinal.

The rows panel contain information about the number of rows (observations), number of rows deleted from analysis, number of rows selected, etc.

Collectively, the data table panels contain the metadata for each JMP data table.

Entering Data

Beginning with File > New > Data Table, a blank table appears.  Our goal is to enter data into the data grid.

[image: image3.wmf]
Initially, we want to add rows and columns to the table.  The red triangular controls, [image: image4.wmf], associated with the row and column panels may be used for this purpose.  Select Add Rows from the row panel control or New Column from the column panel control to add row and/or columns to the data table.

Entering Data

Adding rows to the table is straight-forward.  After selecting New Column the user is presented a dialog box in which column properties are specified.

[image: image5.wmf]
In most cases you will want to change the column name from the “Column x” default.  The primary data types are Numeric and Character.  The choices for Modeling Type are Continuous, Nominal and Ordinal.  Numerous formats are available.  They are used to alter the display of a column’s values.  Initial data values may be used to fill in a column.  For instance you may want to fill in one column with integers running from 1 to n=the number of rows as an ID column.  Column properties may be used to specify several column characteristics.  We will look at some of those momentarily.

Once row and columns are created the data may be entered in the same manner one enters data into EXCEL, for instance.

Example

[image: image6.wmf]
Treatment group identifies which of two treatments each subject received.  Subject is identified by ID.  The next two columns indicate whether or not each subject was determined to exhibit symptoms of neuropathy (by a neurologist) and whether or not the subject reported cramps alone from a list of physical discomforts.  The following three columns contain chemical concentrations of various substances for each subject.

Data Manipulation

Standard data manipulation may be accomplished through operations available in the Tables Menu on the main menu bar.
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Sort, Subset, Concatenate, Update and Join (merge) are familiar SAS data step operations.  Stack corresponds to making many observations out of a single observation by stacking the values from many columns into one column.  Split is the opposite of that operation.

Something like PROC MEANS

Often we want summary statistics for selected columns, ordinarily grouped by another column.  Choosing Summary from the Tables menu, you get a dialog box.  We have requested some statistical summaries for GAD separated by Treatment group.

[image: image8.wmf]
The JMP table, Irvinex By(Treatment group), below is produced.
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The resulting table not only contains the information requested by can be used in subsequent analysis requests – such as for graphical displays.

Bar Charts

With the Irvinex By(Treatment group) data table active select Graph > Chart to get this dialog box.

[image: image10.wmf]
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“Data” was used to select Mean(GAD) as the plotting value.  Treatment group was selected to identify the groups being compared in the graph.

Creating New Columns

One of the primary functions of the SAS data step is to allow the user to create new variables using the values of existing variables.  In JMP that may be done using the formula editor.  Select New Column from the columns panel control.  For no particularly good reason suppose that we want to create a new column by adding the values of GAD and IA2 together.  After assigning a column name in the Column Name area we select Formula from the Column Properties list.  The formula editor opens.  Select GAD from the Table Columns list.  Select + from the keypad (to the right of the Table Columns list).  Select IA2 from the Table Columns list.  See the display on the next page.

Formula Editor

[image: image12.wmf]
After selecting OK twice Irvinex.jmp should appear as on the following page.

The New Table

[image: image13.wmf]
Adding GAD and IA2 together has no useful purpose so select the new column then go to the columns menu and delete the new column.  More usefully we might observe that none of the observations where Cramps Only is equal to 1 have Symptoms of Neuropathy equal to 2.  Cramps alone are not sufficient for a neurologist to place a person in that category.  We now decide to create a column that treats cramps alone as a symptom of neuropathy.  We want “Y” to indicate that there are such symptoms and “N” to indicate that there are not.  As before, we use New Column to begin the process.  Name the new column “S or C?”.  Change the data type to Character.  Select Formula from the Column Properties list.  The formula editor should appear.  

Creating S or C? – If … Then … Else … Logic

Choose Conditional from the Function list on the right hand side of the display.  From the submenu choose IF.  Select Symptoms of Neuropathy.  Select = on the keyboard.  Enter “2” in the blank box after the equal sign.  Select the thin gray line around the If clause just entered.  Choose Conditional again and select OR from the submenu.  Choose Conditional and select IF again.  Select Cramps Only.  Select = on the keyboard and enter “1” into the box automatically selected.  Enter “Y” into the area labeled “then clause”.  Enter “N” into the area labeled “else clause”. [image: image14.png]| Symproms of newropathy: baseline =2 | Cramps onty =L ="Y'
else >N





Select OK, OK to view the data table with the S or C? column appended on the right hand side.

[image: image15.wmf]
The + next to S or C? in the columns panel indicates that S or C? is calculated from a formula.

Analyzing Data in JMP

Most statistical analyses in JMP are performed from either the Analyze or Graph drop down menus on the main menu bar.  Most of the traditional methods of statistical inference, including hypotheses testing, are found on the Analyze menu while several graphical/inferential methods, especially those related to quality control may be found on the Graph menu.

Beginning with simple data summarizations such as those which might be carried out in the SAS programming environment using procedures such as MEANS, FREQ or, GCHART we will explore in the Irvine2 data set.  Go to the Analyze menu and select Distribution.
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A dialog box appears

[image: image17.wmf]
Select HBA00 and Symptoms at Baseline and place them in the “Y Columns” area.  The following two graphs are displayed along with text reports.

HBA00



 Symptoms: baseline
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The Distribution Platform

Alternately click on the two parts of the bar-graph for Symptoms and watch the bar-graph for HBA00.  It does appear that the HBA00 values are lower when Symptoms=2 than when Symptoms=1.  This is just one way in which JMP makes exploratory data analysis extraordinarily easy.

The text reports below the two bar-graphs give numerical summaries for HBA00 and Symptoms.  Note that the summaries are different depending on whether the column is continuous or categorical (nominal or ordinal).

The Fit Y by X Platform

It is not a good idea to use exploratory methods to suggest certain hypotheses and then to test those hypotheses on the same data that suggested them.

We will imagine that the data were collected with a view toward establishing an association between HBA00 and Symptoms at Baseline.  To test


Ho: 1 = 2 against Ha: 1 = 2

using a t-test, we use Fit Y by X from the Analyze menu.  Select HBA00 for the role of Y and Symptoms for the role of X.

[image: image21.wmf]
Select OK.  A dot-plot will appear.  From the red triangle control at the top of the display select Means/Anova/Pooled t.

The Display

[image: image22.wmf]
We see that the mean of HBA00 for those with symptoms is 7.654 while for those who did not have symptoms it is 9.5448 and that the difference is statistically significant with a p-value of .005.

Logistic Regression – Reversing the Roles of X and Y

If we rerun the analysis except reverse the roles of the variables so that HBA00 is now X and Symptoms of Neuropathy is now Y we get the following.  Again the association is significant.
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The Null Hypothesis and Horizontal Lines

The graph on the previous slide displays the predicted probability of the outcome, 1, as a function of HBA00.  If the predicted probability was constant then the graph would present a horizontal line.  The graph on the previous page is far from being horizontal so the visual evidence against Ho is strong.
Fit Y by X

When the Y column is continuous and the X column is categorical JMP produces tests of equal means across levels of the X variable.  When there are just two values of X (groups) JMP produces t-tests.  We will consider the case of more than 2 groups a little bit later.

If both the X and Y columns are continuous then JMP produces a regression analysis with scatter plots and statistical summaries appropriate to that situation.

Again select Fit Y by X from the Analyze menu.  Select HBA00 as X and GAD as Y.

[image: image24.wmf]
Select OK.  From the red triangle control in the resulting analysis window select Fit Line.

The Display
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[image: image26.png]—— Linear Fit





Linear Fit

GAD = 0.6921568 - 0.0331348 HBA00

Summary of Fit

	 
	 

	RSquare
	0.020923

	RSquare Adj
	-0.01404

	Root Mean Square Error
	0.331192

	Mean of Response
	0.386333

	Observations (or Sum Wgts)
	30


Analysis of Variance

	Source
	DF
	Sum of Squares
	Mean Square
	F Ratio

	Model
	1
	0.0656347
	0.065635
	0.5984

	Error
	28
	3.0712620
	0.109688
	Prob > F

	C. Total
	29
	3.1368967
	
	0.4457


Parameter Estimates

	Term
	 
	Estimate
	Std Error
	t Ratio
	Prob>|t|

	Intercept
	
	0.6921568
	0.399949
	1.73
	0.0945

	HBA00
	
	-0.033135
	0.042835
	-0.77
	0.4457


Interpreting the Results

The least-squares regression line, its equation and several other statistics associated with regression analyses are displayed.  The hypothesis Ho:  = 0 suggests no linear association between HBA00 and GAD.  In this case the p-value associated with a test of that hypothesis is .4457 so we fail to reject Ho.  While that doesn’t prove the “no association” hypothesis we must conclude that we have little reason to believe that there is a linear association between the two columns.

Select Confidence Curves Fit from the red triangular control next to Linear Fit.

[image: image27.wmf]
The dotted lines correspond to upper and lower 95% confidence limits for the mean value of Y at each value of X.

The Null Hypothesis and Horizontal Lines

[image: image28.png]04





If we select Fit Mean from the red control near the top of the display a horizontal line is added to the plot.  The constant y-value corresponds to the mean of GAD.  If the horizontal line is completely contained between the dotted confidence interval bounds the resulting hypothesis testing will be non-significant.  If the horizontal line is so contained then the hypothesis test will produce a significant outcome.

A Quadratic Fit

While scatter plot gives us little reason anticipate that any curvilinear relationship exists between the columns we will demonstrate that JMP can fit such equations in two ways. First select Remove Fit from the Linear Fit menu.  Then select Fit Polynomial > 2, quadratic from the Bivariate Fit control.  Then select Confid Shaded Fit from the control next to Polynomial Fit.  The following display appears along with some numerical summaries.
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The shaded area corresponds to upper and lower 95% confidence limits for the mean value of Y at each value of X.

Mix and Match Transformations

Again, select Remove Fit from the Polynomial Fit control.  Then Select Fit Special from the Bivariate Fit control menu.  The following appears.

[image: image30.wmf]
Use the radio buttons in the dialog box to specify a Natural Log transformation for Y and a Square Root transformation for X.  Select OK.  Select Plot Residuals from the Transformed Fit control.  The results appear on the next page.

Results
[image: image31.wmf]
Interpretation and Saving Your Work

Despite the “cleverness” of the model please note that nothing is significant, the fitted line doesn’t describe the data very well and the residual plot indicates that we have underfit the GAD values for mid-sized levels of HBA00 and overfit them for both low and high values of HBA00.  Select Script > Save Script to Data Table from the Bivariate Fit control.

[image: image32.wmf]
“Bivariate” appears in the Table Panel on left hand side of the data table.
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Re-running an Analysis

Select Run Script from the drop down menu next to Bivariate in the Table Panel.  
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An analysis appears just as it was when we saved it and we are ready to proceed from where we left off.  You do not have to restart your work every time you sit down.

Some New Data

Blood Stains at the crime scene are important clues used by investigators.  It is often important to be able to establish the age of the blood stain.

This data comes from 32 blood samples used to stain a certain type of cloth.  The samples were stored at one of two humidity levels for a period of 1, 3, 20 or 90 days.  In this study the ratio of two types of RNA (from Reverse Transcriptase-Polymerase Chain Reaction) is the response in this experiment.  It is hoped that the ratio will be associated with age.  Initially, we will ignore humidity in our analysis.

[image: image35.wmf]
The [image: image36.wmf] symbol next to Ratio in the Columns Panel indicates the column is locked so the values can’t be edited.  The column is locked because the values were originally calculated from other columns in the formula editor.

ANOVA

We want to see if Ratio is associated with day.  In formal terms we want to test

1 = 3 = 20 =90

against the alternative hypothesis that not all the means are the same,

Select Fit Y by X from the Analyze menu.  Specify Ratio as the Y variable and day as the X variable.

[image: image37.wmf]
Select OK and choose Means/Anova from the menu on Oneway Analysis control to obtain the following.

ANOVA Results

[image: image38.wmf]
The green diamond’s tops and bottoms indicate upper and low limits of 95% confidence intervals for the mean of each group while the width of each diamond is proportional the group sample size.  The diamond’s centerline is the mean for each group.

ANOVA Results

From the diamonds and from the “Means for Oneway Anova” report it is quite easy to see an apparent upward trend in Ratio as day increases.  The p-value, <.0001, indicates that the means are significantly different.  In order to compare pairs of JMP provides several methods of means separation. The one we will illustrate here is the method of least significant differences based on Student’s-t. From the Oneway Analysis control menu select Compare Means > Each Pair, Student’s-t.  An abbreviated set of results is displayed below.

[image: image39.wmf]
ANOVA Results

The “circles” correspond to the tops and bottoms of the group confidence intervals.  You may click to select any circle (group).  That circle appears in bold red.  Other groups which are not significantly different will be represented by lighter red circles while groups that are significantly different will be represented by gray circles.

In the second panel means for each group are listed (high to low).  Levels 3 and 20 are connected by the letter B so their means are not significantly different.  Per contra, levels 1 and 20 are not connected by the same letter so their means are significantly different.  

The third panel contains the differences between each of the six pairs of means, a confidence interval for the true difference and a p-value for testing equivalence.

Multifactor ANOVA

The AoVex.jmp data set contains a second factor, Humidity.  In order to investigate the effect of day, Humidity and the interaction of the two we will use the Fit Model platform.  Choose Fit Model from the Analyze menu.  The following dialog will appear.

[image: image40.wmf]
Select Ratio as Y.  Add Humidity and day to the model effects area.  Choose Humidity and day and click Cross to add the interaction term.  Select Run Model.  Partial results are display on the next page.

Fit Model Results

[image: image41.png]v Analysis of Variance
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The upper panel contains “whole model” results.  The significant p-value (.0002) refers to a test of the hypotheses that none of the 3 factors; Humidity, day or Humidity*day have any effect on Ratio.  We readily reject that hypothesis.  The lower panel separates out the 3 factors and the test results for each.  Of the three only Day is significant.

Factor Profiling

It is convenient if we can visualize the predicted values of Ratio for different levels of the two factors. 

From the control menu in the upper left hand corner select Factor Profiling > Surface Profiler.  That produces the following display of the predicted values of the response for each combination of predictors.

[image: image43.wmf]
Various dialogs and controls to the right of the surface profiler can be used to alter the appearance of the display.

Power and Sample Size

The p-value for Humidity is at least close enough to significance so that we might be tempted to try another experiment with an increased sample size in order to see if we can’t establish a Humidity effect.
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From the red control select Power Analysis.  A dialog box appears.

Power - Retrospectively
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A range of significance levels (), standard deviations (), effect sizes () and sample sizes (Number) may be investigated.  Default values for  and  are based on the sample data.  We might be interested in finding the power associated with these settings for larger samples.  If we fill in the blanks as follows we get power calculations for sample of size 60, 70, … , 150.  Those appear on the next page.
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Power
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Apparently, with a total sample size of 110 we would have ~80% power and with a total sample size of 150 we would have ~90% power (assuming all of our specifications are accurate – which is a lot to assume).  Note that by using the From:, To: and By: specifications you may examine an array of possibilities for parameter specifications.

Power – Prospectively
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There are many reasons why retrospective estimates of power are discouraged.  JMP also permits the user to examine an array of possibilities with respect to power and sample size for a particular set of externally derived specifications.  Select Sample Size and Power from DOE on the main menu bar.

Power – Prospectively
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JMP presents power/sample size calculations for a number of hypothesis testing situations.  For this example suppose we choose k Sample Means and fill in the specifications as shown on the next page.

Power Prospectively
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If exactly one of sample size or power is specified then the other is calculated.  If neither of them are specified then the following graph displays the association between the two.

Power/Sample Size Graph
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We see that a sample of size 16 (four per group) results in a power of about 90%.  For a better sense of the power associated with a particular sample size and vice-versa select the crosshairs from the Tools menu, or the tool bar.

Power/Sample Size Graph
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For the specifications given the power associated with n=16 is now seen to be about 91%.

Fit Y by X

Choosing X to be continuous or categorical and choosing Y to be continuous or categorical leads to 4 possibilities.  We have looked at 3 of them already.  The Fit Y by X – Contextual dialog window displays the different analyses.
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· Bivariate, both variables continuous, results in regression/correlation analyses.

· Oneway, X categorical – Y continuous, results in ANOVA/t-test analyses.

· Logistic, X continuous – Y categorical, results in logistic regression analysis.

· Contingency, both variables categorical, results in contingency table analysis often associated with Chi-Square tests.

We will use Titanic.jmp from the sample data library that is distributed with the software.

Contingency Tables
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This data set consists of 2201 rows, one for each person onboard that fateful night.  The columns indicate the Class of service (first, second, third & crew), Age (Child, Adult), Sex (Female, Male), Survived (yes, no).  Our goal is to examine the association between Class and Survived.

Select Fit Y by X from the Analyze menu.

Specify Survived as Y and Class as X.
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Select OK

Contingency Tables

[image: image56.wmf]QuickTime™ and a

TIFF (LZW) decompressor

are needed to see this picture.



Contingency Tables

The graphic display must be viewed with some caution since the vertical axis corresponds to the proportion where Survived=no (the proportion people who died).  We see that people in third class and the crew did relatively worse than those in first or second class.  Both the likelihood ratio and Pearson tests indicate that the observed differences between the survival rates in the various classes of service are unlikely to be due to chance.

Much of the display on the previous page is the same as we get from PROC FREQ.

Similar analyses can be used to investigate survival rates for Age and for Sex.

Categorical Responses & Multiple Factors

Just as multifactor ANOVA may be used to simultaneously investigate the effects of several factors on a continuous outcome, we can do multifactor studies when the response is categorical.  Continuing with the Titanic data we will look at the effect of Class, Age and Sex on survival.  Choose Fit Model from the Analyze menu.  Choose Survived as Y and the other 3 columns as X then choose Run Model.
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Categorical Responses & Multiple Factors
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Clearly, all 3 factors are highly significant.  The Lack of Fit display indicates that the observed proportions depart from the predictions of the 3 variable model in a significant way.  Use Remove to clear the three model effects.

Click and drag over Class, Age and Sex in the select columns area and choose Factorial to Degree from the Macros control.

Specifying Interactions
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The default value of “degree” is 2.  That means that all 2 factor interactions formed by combinations of the selected variables are added to the model in addition to the main effects.  The model effect section should now look like
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Select Run Model.

Results from the 2 FI model
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The p-value for the Lack of Fit test, .9961 indicates that this more complex model fits the set of observed probabilities quite well.  Two of the three interaction terms are significant.

The prediction profiler is useful for the purposes of understanding the nature of the interactions.

Select Profiler from the red control in the upper right-hand corner of the display.

Profiler
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Focus on the bottom half of the display, the predicted probability Survived=yes.  The vertical red lines correspond to settings.  So, for instance, the leftmost plot displays the predicted probability of survival given Age=adult and Sex=female.  Previously shown results indicate a fairly strong Class*Sex interaction.  To get a better sense of what the means go to the rightmost plot and move the vertical red line to male.  Just clicking above male will do that.  The profiler now changes the leftmost and center plots to reflect the new value of Sex.  The bottom portion of the Prediction Profiler is displayed on the next page.

Profiler
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The association between survival and class of service depends on Sex in the following way.  Among females, those in third class were much less likely to survive than others.  Among males survival chances were much more uniform.  Indeed, males in third class did a little bit better than males in second class.

Multiple Regression
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The data set partially displayed above contains average SAT scores, average teacher pay, per pupil spending and the % of High School Seniors who take the SAT for the 50 states and the District of Columbia.  We are interested in establishing which of the other three factors have a linear association with SAT scores.

Select Fit Model from the Analyze menu.  Specify SAT as the Y variable and the other 3 variables as effects.  Select Run Model.  A large number of text reports and graphical displays result.  A few of those appear on the next page.

Multiple Regression

Summary of Fit

	 
	 

	RSquare
	0.780972

	RSquare Adj
	0.766991

	Root Mean Square Error
	31.26428

	Mean of Response
	945.549

	Observations (or Sum Wgts)
	51


Analysis of Variance

	Source
	DF
	Sum of Squares
	Mean Square
	F Ratio

	Model
	3
	163806.22
	54602.1
	55.8614

	Error
	47
	45940.40
	977.5
	Prob > F

	C. Total
	50
	209746.63
	
	<.0001


Parameter Estimates

	Term
	 
	Estimate
	Std Error
	t Ratio
	Prob>|t|

	Intercept
	
	1003.3846
	30.30503
	33.11
	<.0001

	% SAT
	
	-2.724087
	0.264448
	-10.30
	<.0001

	Pay
	
	-1.20383
	1.561872
	-0.77
	0.4447

	Spending
	
	0.0138677
	0.00649
	2.14
	0.0379


Several statistics associated with regression are presented including the estimated coefficients of the regression model.  The prediction equation is

SAT = 1003 – 2.72 %SAT -1.20 Pay +.014 Spending

Pay has a non-significant effect while both Spending and %SAT have significant effects.

Leverage plots may be used to see how an individual observation might affect the value of a particular model coefficient.  Leverage plots may be thought of as scatterplots of Y against one of the X variables where the effect of all other variables has been removed from both Y and X.  The leverage plot for %SAT appears on the next page.

Leverage Plots
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We see a clear trend in which higher SAT scores are associated with lower % SAT values.  Most probably that is related to the fact that many states don’t use the SAT for admission to that state’s colleges and universities.  In those states it is likely that disproportionately many of the very good students take the SAT in hopes of attending an elite school.

The “SC” in the lower right corner of the plot indicates that the nearby point is for South Carolina.  All of the 3 points in the lower right part of the plot are southeastern states (SC, NC and GA).

More Complex Models

Prediction models may involve polynomial and cross-product terms.  One such model that is commonly used is the second-order response surface model.  That model contains a constant, linear terms, quadratic terms and all cross-products.  For 3 predictors the generic form is:

Y=b0+b1X1+b2X2+b3X3+b11X12+b22X22+b33X32

+b12X1X2+b13X1X3+b23X2X3.

Usually, when we get to this part of an analysis, we are less interested establishing the significance of particular effects than we are in finding a good prediction model.

It would be tedious to enter all of the needed model effects into the Fit Model dialog for three factors.  For many variables the effort would be prohibitive.  Fortunately, there is a shortcut.

Response Surfaces

Select Analyze => Fit Model and select SAT as the Y variable.  Select the 3 predictors from the columns list and choose Response Surface from the Macros control.
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The effects area should be populated with all nine response surface effects.

Response Surfaces

The model effect area should look as follows.
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Select Run Model.

Since we are primarily interested in prediction it is useful to be able to view the model graphically.  There are two easy ways to view the model.

Select Factor Profiling => Contour Profiler from the red control in the upper left-hand corner of the display.
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Contour Profiler

The display may be altered using the Profiler Control Panel above the graph.

[image: image69.wmf]QuickTime™ and a

TIFF (LZW) decompressor

are needed to see this picture.


Variables may be selected for the horizontal and vertical axes.  The orientation of the display can be changed with a mouse click-drag on the graph itself.

You may also view the model through the surface profiler.  To do that select Factor Profiling => Surface Profiler from the red control in the upper left-hand corner of the display.
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Surface Profiler

As was the case for the contour profiler, the surface profiler display may be altered using a control panel.  This time it appears to the right of the surface plot.
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In addition, the color and position of the light source illuminating the surface plot can be changed using the circular controls along the boundaries of the plot.
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Variable Selection

In the exploratory phase of regression analysis we are often faced with a large number of potential predictor variables and want sort out those that seem useful from the ones that don’t.  Select Analyze => Fit Model.  Assign SAT the role of Y and add the other 3 variables to Model Effects.  Change the Personality of the platform to Stepwise.
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Select Run Model. 
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Variable Selection
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From the panel above you can simply select Go to do a forward selection of variables.  You can choose Enter All, change Direction to Backward and then select Go to do backward selection.  Starting from either end (everything in the model or nothing in the model) you can set Direction to Mixed to engage a process known as stepwise or mixed variable selection.  In that process variables may enter the model and be removed later or just the opposite.  In this particular case Forward selection results in the display on the following page.

Variable Selection
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Only two of the variables are selected.  

All Possible Models

Forward, backward and stepwise regression selection methods have a long history of use in statistical applications.  There is no guarantee, however, that they will converge on a best model.  It would useful to be able to be able to examine all possible models before choosing one.  Considering only “linear” functions of the variables, for k predictor variables, there are 2k-1 possible models so for large k examining all possible models may be impractical.  Nevertheless, for modest numbers of variables it is possible.  Select All Possible Models from the red control next to Stepwise Fit.
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The model of each size with the largest value of R2 is highlighted.  Notice that there are four models with very similar values of R2 and one of them contains only SAT.  The square root of the mean square error (RMSE) is also given for each model.  It may also be used to select an optimal model.  Selecting the optimal model according to RMSE is equivalent to selecting the model with the lowest adjusted-R2.

The Fit Model Platform

In addition to the features we have already seen, the Fit Model platform may be used to fit models with both fixed and/or mixed effects.  It may also be used to fit generalized linear models, usually to categorical response variables, for any one of four distributions and any one of seven link functions.  Increasingly popular analyses such as Poisson regression are implemented in JMP.  Historically statistical inference has focused on the mean of Y for given X’s much recent interest has focused on dispersion models.  JMP implements a methodology known as LogLinear variance modeling.  

